summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-11 15:36:46 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-11 15:44:07 +0100
commit62141c07f7e4680dd9bf5c644614d7cc14805c51 (patch)
treea6f21445826fc6dee485d2e13422caf0d4a1794e
parent0f6b9e9828dfc269bfc4eade771efed1753e8c62 (diff)
downloadguix-62141c07f7e4680dd9bf5c644614d7cc14805c51.tar.gz
gnu: Rename r-data.table to r-data-table.
* gnu/packages/statistics.scm (r-data.table): Rename variable ...
(r-data-table): ... to this.
[description]: Clarify relation to data.frame.
[license]: Use correct license.
-rw-r--r--gnu/packages/statistics.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 2af9de2344..5482aca35e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -921,9 +921,9 @@ database.")
 times.")
     (license license:gpl2)))
 
-(define-public r-data.table
+(define-public r-data-table
   (package
-    (name "r-data.table")
+    (name "r-data-table")
     (version "1.9.6")
     (source (origin
               (method url-fetch)
@@ -937,10 +937,11 @@ times.")
     (home-page "https://github.com/Rdatatable/data.table/wiki")
     (synopsis "Enhanced version of data.frame R object")
     (description
-     "The R data.table package provides functions for fast aggregation of
-large data (e.g. 100GB in RAM), fast ordered joins, fast add/modify/delete of
-columns by group, column listing and fast file reading.")
-    (license license:gpl2+)))
+     "The R package @code{data.table} is an extension of @code{data.frame}
+providing functions for fast aggregation of large data (e.g. 100GB in RAM),
+fast ordered joins, fast add/modify/delete of columns by group, column listing
+and fast file reading.")
+    (license license:gpl3+)))
 
 (define-public python-patsy
   (package