summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-24 18:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-24 18:18:24 +0100
commit6f1e0bb79266f34b50b09200b9280a641b8aa7c8 (patch)
tree13a00c38cab67172f1b89db36eb3414a593d7a9f
parent3c5e13642ccc6db31ae8a017ea3076e63966ccd3 (diff)
downloadguix-6f1e0bb79266f34b50b09200b9280a641b8aa7c8.tar.gz
gnu: commencement: Do not graft early bootstrap packages.
This is a followup to e47c69f22638dc92ee962942b8e24284c8dee832 and a
repetition of f00b85ff8d34df0a1879e593d4a85629b8586af7.

* gnu/packages/commencement.scm (file-boot0): Use 'inherit' instead of
'package/inherit'.
-rw-r--r--gnu/packages/commencement.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index bd48eb7f80..0aa65fe638 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -126,7 +126,8 @@
 
 (define file-boot0
   (package-with-bootstrap-guile
-   (package-with-explicit-inputs (package/inherit file
+   (package-with-explicit-inputs (package
+                                   (inherit file)
                                    (name "file-boot0"))
                                  `(("make" ,gnu-make-boot0)
                                    ,@%bootstrap-inputs)