summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-25 21:57:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-25 22:05:51 +0200
commitcf51b828af5358c1303bbb797f58433dd8d4c043 (patch)
treeccfe0c7fc91bf5d09934a7a7e0c10d0b2e75cf20
parentf76335740c8e0aff2fee70d4c1062f9f5ff87952 (diff)
downloadguix-cf51b828af5358c1303bbb797f58433dd8d4c043.tar.gz
gnu: translate-shell: Wrap binary.
* gnu/packages/dictionaries.scm (translate-shell)[arguments]: Add custom
phase to wrap the 'trans' binary with the inputs.
[native-inputs]: Move curl, fribidi, rlwrap ...
[inputs]: ... to here.
-rw-r--r--gnu/packages/dictionaries.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index e32df64ec0..9e06ac7124 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -268,6 +268,20 @@ and a Python library.")
            (lambda _
              (delete-file "translate")
              #t))
+         (add-after 'install 'wrap-binary
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out     (assoc-ref outputs "out"))
+                    (bin     (string-append out "/bin/trans"))
+                    (curl    (assoc-ref inputs "curl"))
+                    (fribidi (assoc-ref inputs "fribidi"))
+                    (rlwrap  (assoc-ref inputs "rlwrap")))
+               (wrap-program bin
+                             `("PATH" ":" prefix
+                               (,(string-append out "/bin:"
+                                                curl "/bin:"
+                                                fribidi "/bin:"
+                                                rlwrap "/bin")))))
+             #t))
          (add-after 'install 'emacs-install
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out   (assoc-ref outputs "out"))
@@ -283,7 +297,7 @@ and a Python library.")
                   (guix build emacs-utils)
                   (guix build utils))
        #:test-target "test"))
-    (propagated-inputs
+    (inputs
      `(("curl" ,curl)
        ("fribidi" ,fribidi)
        ("rlwrap" ,rlwrap)))