summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-16 23:32:36 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-17 13:03:50 -0500
commitf8f744a8d1910cddf3b93c5824da8a4d29deab79 (patch)
tree4b667d35824005e44ce20fc07e1bf727c991c485
parent930768b3e45ac66b2e868fe413ca2e35634c26ee (diff)
downloadguix-f8f744a8d1910cddf3b93c5824da8a4d29deab79.tar.gz
gnu: Add Memoize-ExpireLRU.
* gnu/packages/perl.scm (perl-memoize-expirelru): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8100aaa7e8..d28b753a3d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1669,6 +1669,26 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
 functionality on lists which is not going to go into List::Util.")
     (license (package-license perl))))
 
+(define-public perl-memoize-expirelru
+  (package
+    (name "perl-memoize-expirelru")
+    (version "0.55")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/B/BP/BPOWERS/"
+                           "Memoize-ExpireLRU-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0klk0vj78lr259mnv1rbxib8gzf2cfp4zhkhbcxyhadkkl73myvj"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Memoize-ExpireLRU")
+    (synopsis "Expiry plug-in for Memoize that adds LRU cache expiration")
+    (description "This module implements an expiry policy for Memoize that
+follows LRU semantics, that is, the last n results, where n is specified as
+the argument to the CACHESIZE parameter, will be cached.")
+    (license (package-license perl))))
+
 (define-public perl-module-build-tiny
   (package
     (name "perl-module-build-tiny")