summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:41:10 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commit15272a5053f4c70c073713febfbba3c4623f82de (patch)
tree516c79db690f753f40ee8bede234359aa4cb60b5
parent71f3680499d578946193af3db08f19688fb48ce7 (diff)
downloadguix-15272a5053f4c70c073713febfbba3c4623f82de.tar.gz
gnu: Add go-github-com-mr-tron-base58.
* gnu/packages/golang.scm (go-github-com-mr-tron-base58): New variable.
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4ee4a01b43..795ab29838 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2762,3 +2762,30 @@ Architecture Processors\" by J. Guilford et al.")
       (synopsis "Various cryptographic utilities used by IPFS")
       (description "Various cryptographic utilities used by IPFS")
       (license license:expat))))
+
+(define-public go-github-com-mr-tron-base58
+  (let ((commit "d724c80ecac7b49e4e562d58b2b4f4ee4ed8c312")
+        (revision "0"))
+    (package
+      (name "go-github-com-mr-tron-base58")
+      (version (git-version "1.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mr-tron/base58.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "12qhgnn9wf3c1ang16r4i778whk4wsrj7d90h2xgmz4fi1469rqa"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:unpack-path "github.com/mr-tron/base58"
+         #:import-path "github.com/mr-tron/base58/base58"))
+      (home-page "https://github.com/mr-tron/base58")
+      (synopsis "Fast implementation of base58 encoding on Golang")
+      (description "Fast implementation of base58 encoding on Golang.  A
+trivial @command{big.Int} encoding benchmark results in 6 times faster
+encoding and 8 times faster decoding.")
+      (license license:expat))))