summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:00:00 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:22 +0200
commit19789c8b91c5879b6cd13ed5dc0793e0edd66a33 (patch)
treed71d4c6773bb8341621cc638983b1267ff0d0762
parent6fa257cca7b4496d066eb8b730a0634e601c4809 (diff)
downloadguix-19789c8b91c5879b6cd13ed5dc0793e0edd66a33.tar.gz
gnu: Add go-golang-org-x-crypto-sha3.
* gnu/packages/golang.scm (go-golang-org-x-crypto-sha3): New variable.
-rw-r--r--gnu/packages/golang.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3c63925b7d..c114431bab 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1026,6 +1026,19 @@ hash algorithm.")))
     (description "This package provides a Go implementation of the BLAKE2s
 hash algorithm.")))
 
+(define-public go-golang-org-x-crypto-sha3
+  (package
+    (inherit go-golang-org-x-crypto-bcrypt)
+    (name "go-golang-org-x-crypto-sha3")
+    (arguments
+     (substitute-keyword-arguments (package-arguments go-golang-org-x-crypto-bcrypt)
+       ((#:import-path _)
+        "golang.org/x/crypto/sha3")))
+    (synopsis "SHA-3 in Go")
+    (description "This package provides a Go implementation of the SHA-3
+fixed-output-length hash functions and the SHAKE variable-output-length hash
+functions defined by FIPS-202.")))
+
 ;; Go searches for library modules by looking in the GOPATH environment
 ;; variable.  This variable is a list of paths.  However, Go does not
 ;; keep searching on GOPATH if it tries and fails to import a module.