summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 12:00:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:45 +0200
commit1d18ee6dfd99d9945a0e8eae7557250a1bdc6306 (patch)
tree19d025c80af26e1ed1b2562e29844b6c7b1a6e71
parent9a6808e0c00d6acb00b7be4aa573f252fa7d9635 (diff)
downloadguix-1d18ee6dfd99d9945a0e8eae7557250a1bdc6306.tar.gz
gnu: bwa-pssm: Fetch from git.
* gnu/packages/bioinformatics.scm (bwa-pssm)[source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0dc81c8f61..593b5b6202 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1449,13 +1449,14 @@ and more accurate.  BWA-MEM also has better performance than BWA-backtrack for
     (name "bwa-pssm")
     (version "0.5.11")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/pkerpedjiev/bwa-pssm/"
-                                  "archive/" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pkerpedjiev/bwa-pssm.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "02p7mpbs4mlxmn84g2x4ghak638vbj4lqix2ipx5g84pz9bhdavg"))))
+                "076c4q0cdqz8jgylb067y9zmvxglppnzi3qiscn0xiypgc6lgb5r"))))
     (build-system gnu-build-system)
     (inputs
      `(("gdsl" ,gdsl)