summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:49:53 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commit1db1e3c79efd6c61632a68a003d0979d0ad5b35f (patch)
treefc3fd23388f3adcbd3ce29e65547d6c8ab2344ca
parent2e42e587b43106980dbd8a6bfee2fd644c1a7f53 (diff)
downloadguix-1db1e3c79efd6c61632a68a003d0979d0ad5b35f.tar.gz
gnu: Add go-github-com-libp2p-go-libp2p-peer.
* gnu/packages/golang.scm (go-github-com-libp2p-go-libp2p-peer): New variable.
-rw-r--r--gnu/packages/golang.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ab78038649..4c36f1eaaf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2906,3 +2906,38 @@ required by Go's standard Hash interface.")
       (synopsis "Multihash implementation in Go")
       (description "Multihash implementation in Go.")
       (license license:expat))))
+
+(define-public go-github-com-libp2p-go-libp2p-peer
+  (let ((commit "993d742bc29dcf4894b7730ba610fd78900be76c")
+        (revision "0"))
+    (package
+      (name "go-github-com-libp2p-go-libp2p-peer")
+      (version (git-version "2.3.8" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/libp2p/go-libp2p-peer.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1h96qjdi0i1wbr0jliap2903mycphas3ny0zdrm77yca9plcnphh"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/libp2p/go-libp2p-peer"))
+      (native-inputs
+       `(("go-github-com-libp2p-go-libp2p-crypto" ,go-github-com-libp2p-go-libp2p-crypto)
+         ("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
+         ("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
+         ("go-github-com-minio-blake2b-simd" ,go-github-com-minio-blake2b-simd)
+         ("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
+         ("go-github-com-mr-tron-base58" ,go-github-com-mr-tron-base58)
+         ("go-github-com-multiformats-go-multihash" ,go-github-com-multiformats-go-multihash)
+         ("go-github-com-gxed-hashland-keccakpg" ,go-github-com-gxed-hashland-keccakpg)
+         ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+         ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))))
+      (home-page "https://github.com/libp2p/go-libp2p-peer")
+      (synopsis "PKI based identities for use in go-libp2p")
+      (description "PKI based identities for use in @command{go-libp2p}.")
+      (license license:expat))))