summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-05 23:47:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-05 23:47:14 +0100
commit2664e0f6808d69eff2b5abb7c5d7763f344713cf (patch)
treea30dee4b938efd8f9fd3ae5d1ac50c87c8428a25
parentda663457da6d038ae38f5c96fe38fc35e93a4f50 (diff)
downloadguix-2664e0f6808d69eff2b5abb7c5d7763f344713cf.tar.gz
gnu: guile: Update to 2.2.3.
* gnu/packages/guile.scm (guile-2.2): Update to 2.2.3.
(guile-2.2.3): Remove variable.
-rw-r--r--gnu/packages/guile.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 90630e8a36..6e8b953957 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -221,7 +221,7 @@ without requiring the source code to be rewritten.")
 (define-public guile-2.2
   (package (inherit guile-2.0)
     (name "guile")
-    (version "2.2.2")                      ;TODO: Update to 2.2.3 (see below).
+    (version "2.2.3")
     (source (origin
               (method url-fetch)
 
@@ -231,7 +231,7 @@ without requiring the source code to be rewritten.")
                                   ".tar.xz"))
               (sha256
                (base32
-                "1azm25zcmxif0skxfrp11d2wc89nrzpjaann9yxdw6pvjxhs948w"))
+                "11j01agvnci2cx32wwpqs9078856yxmvs15gcsz7ganpkj2ahlw3"))
               (modules '((guix build utils)))
 
               ;; Remove the pre-built object files.  Instead, build everything
@@ -251,21 +251,6 @@ without requiring the source code to be rewritten.")
             (files '("lib/guile/2.2/site-ccache"
                      "share/guile/site/2.2")))))))
 
-(define-public guile-2.2.3
-  ;; TODO: Make it the new 'guile-2.2' on the next rebuild cycle.
-  (package
-    (inherit guile-2.2)
-    (version "2.2.3")
-    (source (origin (inherit (package-source guile-2.2))
-                    (uri (list (string-append "mirror://gnu/guile/guile-"
-                                              version ".tar.xz")
-                               (string-append
-                                "https://wingolog.org/priv/guile-"
-                                version ".tar.xz")))
-                    (sha256
-                     (base32
-                      "11j01agvnci2cx32wwpqs9078856yxmvs15gcsz7ganpkj2ahlw3"))))))
-
 (define-public guile-2.2/fixed
   ;; A package of Guile 2.2 that's rarely changed.  It is the one used
   ;; in the `base' module, and thus changing it entails a full rebuild.