summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-08-29 01:27:04 -0400
committer宋文武 <iyzsong@member.fsf.org>2018-09-15 12:19:06 +0800
commit2ee67781ff3246c32e4dcdfb3a9adc65967b33dd (patch)
tree9ec720475e43472146c142b0c417986bf7642bc1
parent935d5ceb9bf6f8a759298521da2712db1ec12670 (diff)
downloadguix-2ee67781ff3246c32e4dcdfb3a9adc65967b33dd.tar.gz
gnu: Add python-ua-parser.
* gnu/packages/python.scm (python-ua-parser, python2-ua-parser): New variables.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a5da46dfdb..3c8b68ee1e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5006,6 +5006,31 @@ toolkit.  Use it to build trees of widgets.")
 (define-public python2-urwidtrees
   (package-with-python2 python-urwidtrees))
 
+(define-public python-ua-parser
+  (package
+    (name "python-ua-parser")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ua-parser" version))
+       (sha256
+        (base32
+         "1jwdf58rhchjzzrad405pviv0iq24xa2xmmmdgcm2c8s6b4wzfwp"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;no test suite in release
+    (native-inputs
+     `(("python-pyyaml" ,python-pyyaml)))
+    (home-page "https://github.com/ua-parser/uap-python")
+    (synopsis "User agent parser")
+    (description
+     "@code{ua-parser} is a Python port of Browserscope's user agent parser.")
+    (license license:asl2.0)))
+
+(define-public python2-ua-parser
+  (package-with-python2 python-ua-parser))
+
 (define-public python-dbus
   (package
     (name "python-dbus")