summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:11:41 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:50 +0200
commit38566e975ec9a743f724efecd9829ebf630f6806 (patch)
treee35bcd384805956e963ecd6a35481856806f6923
parent7bd9020e48467fb05950c84eaf29460b449d7c1c (diff)
downloadguix-38566e975ec9a743f724efecd9829ebf630f6806.tar.gz
gnu: Add go-github-com-whyrusleeping-progmeter.
* gnu/packages/golang.scm (go-github-com-whyrusleeping-progmeter): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 34d60110c4..de4e3f29cf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3260,3 +3260,28 @@ fast and distributable command line applications in an expressive way.")
       (description "A library to query JSON objects marshalled into
 @command{map[string]interface{}}.")
       (license license:expat))))
+
+(define-public go-github-com-whyrusleeping-progmeter
+  (let ((commit "f3e57218a75b913eff88d49a52c1debf9684ea04")
+        (revision "0"))
+    (package
+      (name "go-github-com-whyrusleeping-progmeter")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/whyrusleeping/progmeter.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0xs8rz6yhpvj9512c5v3b8dwr2kivywnyyfxzdfbr6fy1xc8zskb"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path
+         "github.com/whyrusleeping/progmeter"))
+      (home-page "https://github.com/whyrusleeping/progmeter")
+      (synopsis "Progress meter for Go")
+      (description "Progress meter for Go.")
+      (license license:expat))))