summary refs log tree commit diff
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 09:22:36 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-22 22:09:51 +0800
commit50401c2a6853a65d89ab9be3f24a4f5386e3b684 (patch)
treeb54b01f26608ec5d00269ba8792d5df88ebe6990
parent51f4e36cb9cc45493397bc799f7a87e5de92560d (diff)
downloadguix-50401c2a6853a65d89ab9be3f24a4f5386e3b684.tar.gz
gnu: libqtxdg: Update to 3.2.0.
* gnu/packages/lxqt.scm (libqtxdg): Update to 3.2.0.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lxqt.scm33
1 files changed, 21 insertions, 12 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index c84d26d4cb..57dd5b9c2f 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,25 +37,33 @@
 (define-public libqtxdg
   (package
     (name "libqtxdg")
-    (version "1.2.0")
+    (version "3.2.0")
     (source
      (origin
        (method url-fetch)
-       (uri
-         (string-append "https://github.com/lxde/libqtxdg/releases/"
-                        "download/" version "/" name "-" version ".tar.xz"))
+       (uri (string-append
+             "https://github.com/lxqt/" name "/releases/download/"
+             version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32
-         "1ncqs0lcll5nx69hxfg33m3jfkryjqrjhr2kdci0b8pyaqdv1jc8"))))
+        (base32 "0lq548pa69hfvnbj2ypba5ygm8n6v6g7bqqm8p5g538l1l3394cl"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ; test fails with message "Exception"
-       #:configure-flags '("-DBUILD_TESTS=ON")))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(#:configure-flags
+       `("-DBUILD_TESTS=ON"
+         ,(string-append "-DQTXDGX_ICONENGINEPLUGIN_INSTALL_PATH="
+                         %output "/lib/qt5/plugins/iconengines"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Run the tests offscreen.
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
     (propagated-inputs
-     `(("qtbase" ,qtbase))) ; according to Qt5Xdg.pc
-    (home-page "https://github.com/lxde/libqtxdg")
+     ;; required by Qt5XdgIconLoader.pc
+     `(("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)))
+    (home-page "https://github.com/lxqt/libqtxdg")
     (synopsis "Qt implementation of freedesktop.org xdg specifications")
     (description "Libqtxdg implements the freedesktop.org xdg specifications
 in Qt.")