summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-07 14:32:36 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-07 14:32:36 +0200
commit538cc2e0165a32d3c5de9022f522f37880b60f5d (patch)
treec27a357bdb68676c0739ebc6e8ba270f8e387ee6
parentce2df078d7b8e8d44b831270421513bd04429866 (diff)
downloadguix-538cc2e0165a32d3c5de9022f522f37880b60f5d.tar.gz
Remove now unneeded (guix build gnome) module.
* guix/build/gnome.scm: Remove.
* Makefile.am (MODULES): Update accordingly.
-rw-r--r--Makefile.am1
-rw-r--r--guix/build/gnome.scm31
2 files changed, 0 insertions, 32 deletions
diff --git a/Makefile.am b/Makefile.am
index 22bbdca13c..14e9e4a4b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,7 +59,6 @@ MODULES =					\
   guix/build/download.scm			\
   guix/build/cmake-build-system.scm		\
   guix/build/git.scm				\
-  guix/build/gnome.scm				\
   guix/build/gnu-build-system.scm		\
   guix/build/gnu-dist.scm			\
   guix/build/linux-initrd.scm			\
diff --git a/guix/build/gnome.scm b/guix/build/gnome.scm
deleted file mode 100644
index cac4de8f24..0000000000
--- a/guix/build/gnome.scm
+++ /dev/null
@@ -1,31 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix build gnome)
-  #:export (gir-directory))
-
-;;; Commentary:
-;;;
-;;; Tools commonly used when building GNOME programs.
-;;;
-;;; Code:
-
-(define (gir-directory inputs pkg-name)
-  "Return the GIR directory name for PKG-NAME found from INPUTS."
-  (string-append (assoc-ref inputs pkg-name)
-                 "/share/gir-1.0"))