summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-05 06:14:29 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-10-19 17:00:24 +0100
commit540d6cc71111809a765d429188868ec3450f77d7 (patch)
treef234396bccfd2d2c3d20e8dfcdfe1f968d9262de
parent152ffe7cb6ba02915d8645102e0f6dfeb639090d (diff)
downloadguix-540d6cc71111809a765d429188868ec3450f77d7.tar.gz
gnu: notmuch: Update to 0.23.
* gnu/packages/mail.scm (notmuch): Update to 0.23.
[home-page]: Use https URL.
(python-notmuch)[version]: Inherit from notmuch.
[home-page]: Ditto.
-rw-r--r--gnu/packages/mail.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0be0929e92..680b227da0 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -499,18 +499,18 @@ invoking @command{notifymuch} from the post-new hook.")
 (define-public notmuch
   (package
     (name "notmuch")
-    (version "0.22.1")
+    (version "0.23")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://notmuchmail.org/releases/notmuch-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0jwpda3q023dn3sp41n8648951i7iagfv8zzpriv7hpkjivlafg7"))))
+                "1f51l34rdhjf8lvafrwybkxdsdwx8k9397m7qxd8rdg2irjmpry5"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ; FIXME: 694 tests; 170 fail and 100 are skipped
-                   ; with perl input: 50 fail and 100 are skipped
+     '(#:tests? #f ; FIXME: 723 tests; 187 fail and 100 are skipped
+                   ; with perl input: 67 fail and 100 are skipped
        #:phases (modify-phases %standard-phases
                   (replace 'configure
                     (lambda* (#:key outputs #:allow-other-keys)
@@ -533,7 +533,7 @@ invoking @command{notifymuch} from the post-new hook.")
        ("talloc" ,talloc)
        ("xapian" ,xapian)
        ("zlib" ,zlib)))
-    (home-page "http://notmuchmail.org/")
+    (home-page "https://notmuchmail.org/")
     (synopsis "Thread-based email index, search, and tagging")
     (description
      "Notmuch is a command-line based program for indexing, searching, read-
@@ -584,7 +584,7 @@ useful for email address completion.")
 (define-public python-notmuch
   (package
     (name "python-notmuch")
-    (version "0.22.1")
+    (version (package-version notmuch))
     ;; Notmuch python bindings are now unavailable on pypi.  The
     ;; bindings are distributed via the notmuch release tarball.
     (source (package-source notmuch))
@@ -606,7 +606,7 @@ useful for email address completion.")
                  (("libnotmuch\\.so\\.")
                   (string-append notmuch "/lib/libnotmuch.so.")))
                #t))))))
-    (home-page "http://notmuchmail.org/")
+    (home-page (package-home-page notmuch))
     (synopsis "Python bindings of the Notmuch mail indexing library")
     (description
      "This package provides Python bindings to use the Notmuch mail indexing