summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:12:40 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:50 +0200
commit56eb7bd33c7c698253be91a932ed3cc8fc85ab6f (patch)
tree69a6fd1ce01a6a17425ad3acef4e2dc059325a05
parent38566e975ec9a743f724efecd9829ebf630f6806 (diff)
downloadguix-56eb7bd33c7c698253be91a932ed3cc8fc85ab6f.tar.gz
gnu: Add go-github-com-whyrusleeping-stump.
* gnu/packages/golang.scm (go-github-com-whyrusleeping-stump): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index de4e3f29cf..9b469072c4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3285,3 +3285,28 @@ fast and distributable command line applications in an expressive way.")
       (synopsis "Progress meter for Go")
       (description "Progress meter for Go.")
       (license license:expat))))
+
+(define-public go-github-com-whyrusleeping-stump
+  (let ((commit "206f8f13aae1697a6fc1f4a55799faf955971fc5")
+        (revision "0"))
+    (package
+      (name "go-github-com-whyrusleeping-stump")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/whyrusleeping/stump.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1s40qdppjnk8gijk7x6kbviiqz62nz3h6gic2q9cwcmq8r5isw7n"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/whyrusleeping/stump"))
+      (home-page "https://github.com/whyrusleeping/stump")
+      (synopsis "Very basic logging package for Go")
+      (description "A simple log library, for when you don't really care to
+have super fancy logs.")
+      (license license:expat))))