summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 10:59:50 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:22 +0200
commit6fa257cca7b4496d066eb8b730a0634e601c4809 (patch)
tree5d75d4b7e5c7f9f85d97c29cce37bb9331621d53
parenta9010ead4c727e3dfd3ebd04fabcc915d54f799d (diff)
downloadguix-6fa257cca7b4496d066eb8b730a0634e601c4809.tar.gz
gnu: Add go-golang-org-x-crypto-blake2s.
* gnu/packages/golang.scm (go-golang-org-x-crypto-blake2s): New variable.
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 66f2b729c5..3c63925b7d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1014,6 +1014,18 @@ signature algorithm.")))
     (description "This package provides a Go implementation of the RIPEMD-160
 hash algorithm.")))
 
+(define-public go-golang-org-x-crypto-blake2s
+  (package
+    (inherit go-golang-org-x-crypto-bcrypt)
+    (name "go-golang-org-x-crypto-blake2s")
+    (arguments
+     (substitute-keyword-arguments (package-arguments go-golang-org-x-crypto-bcrypt)
+       ((#:import-path _)
+        "golang.org/x/crypto/blake2s")))
+    (synopsis "BLAKE2s in Go")
+    (description "This package provides a Go implementation of the BLAKE2s
+hash algorithm.")))
+
 ;; Go searches for library modules by looking in the GOPATH environment
 ;; variable.  This variable is a list of paths.  However, Go does not
 ;; keep searching on GOPATH if it tries and fails to import a module.