summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 15:54:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:25 +0200
commit7cd51cd28e401fc610ad49e3d0d3c8da1598d111 (patch)
treef352986ae512349d6adb11802e33f311579489e2
parent943a4cb60158c28da1348e3b490e958551557d6a (diff)
downloadguix-7cd51cd28e401fc610ad49e3d0d3c8da1598d111.tar.gz
gnu: Add python-toolz.
* gnu/packages/python.scm (python-toolz): New variable.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 59b62fec14..eff28a9102 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14067,3 +14067,25 @@ the saved state of the original interpreter session.")
 which supports the spawning of processes using the API of the standard
 library's @code{threading} module.")
     (license license:bsd-3)))
+
+(define-public python-toolz
+  (package
+    (name "python-toolz")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "toolz" version))
+       (sha256
+        (base32
+         "1j9i7fdjnx9dz35fdj5gvgxx6585ja9sxgaiv65if77nlxz0m7wj"))))
+    (build-system python-build-system)
+    ;; FIXME: tests cannot be computed: "Can't perform this operation for
+    ;; unregistered loader type"
+    (arguments '(#:tests? #f))
+    (home-page "https://github.com/pytoolz/toolz/")
+    (synopsis "List processing tools and functional utilities")
+    (description
+     "This package provides a set of utility functions for iterators,
+functions, and dictionaries.")
+    (license license:bsd-3)))