summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 15:59:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:26 +0200
commitb2b8226244ce176de63ca9f412efca1e3d80984c (patch)
tree249acc4e902bdd082da6c6050a7d8332e154d613
parent930ba31d20f204ca0cee9ea6fedf1aab24195d49 (diff)
downloadguix-b2b8226244ce176de63ca9f412efca1e3d80984c.tar.gz
gnu: Add python-locket.
* gnu/packages/python.scm (python-locket): New variable.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c029fd1410..0a77355fba 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14171,3 +14171,22 @@ is especially useful for cluster computing where Python expressions are
 shipped over the network to execute on remote hosts, possibly close to the
 data.")
     (license license:bsd-3)))
+
+(define-public python-locket
+  (package
+    (name "python-locket")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "locket" version))
+       (sha256
+        (base32
+         "1d4z2zngrpqkrfhnd4yhysh66kjn4mblys2l06sh5dix2p0n7vhz"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/mwilliamson/locket.py")
+    (synopsis "File-based locks for Python")
+    (description
+     "Locket implements a lock that can be used by multiple processes provided
+they use the same path.")
+    (license license:bsd-2)))