summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-07 19:53:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:00:11 +0200
commite1dd78f68a8e0f29c416b5b7b1bbe5dc2cd610fb (patch)
tree35b57697e1de6795df3f03edf1bf9fdd33e4e53e
parent3a068b4307a24015254d2ea8e99d9b677ae8fb75 (diff)
downloadguix-e1dd78f68a8e0f29c416b5b7b1bbe5dc2cd610fb.tar.gz
gnu: Add java-httpcomponents-httpcore-ab.
* gnu/packages/java.scm (java-httpcomponents-httpcore-ab): New variable.
-rw-r--r--gnu/packages/java.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 032f58a587..4716759860 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2095,6 +2095,24 @@ NIO.
 This package provides the non-blocking I/O model library based on Java
 NIO.")))
 
+(define-public java-httpcomponents-httpcore-ab
+  (package (inherit java-httpcomponents-httpcore)
+    (name "java-httpcomponents-httpcore-ab")
+    (arguments
+     `(#:jar-name "httpcomponents-httpcore-ab.jar"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "httpcore-ab") #t)))))
+    (inputs
+     `(("java-httpcomponents-httpcore" ,java-httpcomponents-httpcore)
+       ("java-commons-cli" ,java-commons-cli)
+       ("java-hamcrest-core" ,java-hamcrest-core)
+       ,@(package-inputs java-httpcomponents-httpcore)))
+    (synopsis "Apache HttpCore benchmarking tool")
+    (description "This package provides the HttpCore benchmarking tool.  It is
+an Apache AB clone based on HttpCore.")))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")