summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 15:54:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:25 +0200
commitfc6256725174ec726caa05a33116b64974037509 (patch)
treefc11829bf6e378d32294ee0448f665c53cffae08
parent82d5c7c6de164df56d582ed779f02c6bbfd90b33 (diff)
downloadguix-fc6256725174ec726caa05a33116b64974037509.tar.gz
gnu: Add python-dill.
* gnu/packages/python.scm (python-dill): New variable.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ea1093cf5e..6f9a557c36 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14018,3 +14018,30 @@ scalable way of keeping track of data together with learned annotations and
 reduces the code overhead typically encountered when using a mostly
 object-oriented library such as @code{scikit-learn}.")
     (license license:bsd-3)))
+
+(define-public python-dill
+  (package
+    (name "python-dill")
+    (version "0.2.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "dill" version))
+       (sha256
+        (base32
+         "1cymzn9fxwdy33h21zkk4gqgzvd25110hh3zdqnvnwa3p52c4kb2"))))
+    (build-system python-build-system)
+    ;; FIXME: The check phase fails with "don't know how to make test".
+    (arguments '(#:tests? #f))
+    (home-page "https://pypi.org/project/dill")
+    (synopsis "Serialize all of Python")
+    (description "Dill extends Python's @code{pickle} module for serializing
+and de-serializing Python objects to the majority of the built-in Python
+types.  Dill provides the user the same interface as the @code{pickle} module,
+and also includes some additional features.  In addition to pickling Python
+objects, @code{dill} provides the ability to save the state of an interpreter
+session in a single command.  Hence, it would be feasable to save a
+interpreter session, close the interpreter, ship the pickled file to another
+computer, open a new interpreter, unpickle the session and thus continue from
+the saved state of the original interpreter session.")
+    (license license:bsd-3)))