summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-01 17:02:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-01 17:02:42 +0100
commitc9aeee51ea7243cabbf6b983eacf7ac326e05967 (patch)
treebff5c19a4992b0787fc1888bb77587dc26d46a68
parent2a4f6eb956db11519d82cebc0d56b3393d459a12 (diff)
downloadguix-c9aeee51ea7243cabbf6b983eacf7ac326e05967.tar.gz
WIP
-rw-r--r--gnu/packages/java.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 00fbc1ac70..002d7bed3b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1529,7 +1529,15 @@ new Date();"))
                   (for-each delete-file
                             (find-files "." ".*.(bin|exe|jar)$"))
                   #t))))
-    (build-system gnu-build-system)
+    (build-system
+      (if (string-prefix? "aarch64" (or (%current-system)
+                                        (%current-target-system)))
+          ;; On aarch64 OpenJDK 9 only builds with an older version of GCC.
+          ;; See https://bugs.openjdk.org/browse/JDK-8224851 for details
+          ;; and changes that could be backported.
+          (build-system-with-c-toolchain
+           gnu-build-system `(("gcc" ,gcc-7)))
+          gnu-build-system))
     (outputs '("out" "jdk" "doc"))
     (arguments
      `(#:tests? #f; require jtreg
@@ -1688,14 +1696,7 @@ new Date();"))
        ("make@4.2" ,gnu-make-4.2)
        ("unzip" ,unzip)
        ("which" ,which)
-       ("zip" ,zip)
-       ,@(if (string-prefix? "aarch64" (or (%current-system)
-                                           (%current-target-system)))
-             ;; On aarch64 OpenJDK 9 only builds with an older version of GCC.
-             ;; See https://bugs.openjdk.org/browse/JDK-8224851 for details
-             ;; and changes that could be backported.
-             `(("gcc" ,gcc-7))
-             '())))
+       ("zip" ,zip)))
     (home-page "https://openjdk.java.net/projects/jdk9/")
     (synopsis "Java development kit")
     (description