summary refs log tree commit diff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-08-25 11:44:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-12-29 23:21:26 +0100
commite830bf71f2f2887e138932aca32650c5b1f44be0 (patch)
tree687159ab2edcd63476cf0ae596d5d4b47ccfd04b
parent8d02c4f6182f9c939d0e251166ad0d5ff567c430 (diff)
downloadguix-e830bf71f2f2887e138932aca32650c5b1f44be0.tar.gz
gnu: Add r-mapdata.
* gnu/packages/cran.scm (r-mapdata): New variable.
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a2642fbf26..076cf6aa88 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4015,6 +4015,26 @@ work well on small screens.")
 data store designed for maximum speed.")
     (license license:asl2.0)))
 
+(define-public r-mapdata
+  (package
+    (name "r-mapdata")
+    (version "2.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "mapdata" version))
+              (sha256
+               (base32
+                "0xnxh73rgcq55zrw81a2bq8yd67bxc2rafp4shf6nyrqj04iip0y"))))
+    (properties `((upstream-name . "mapdata")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-maps))
+    (home-page "https://cran.r-project.org/package=mapdata")
+    (synopsis "Extra map databases")
+    (description
+     "This is a supplement to the @code{maps} package providing the larger
+and/or higher-resolution databases.")
+    (license license:gpl2)))
+
 (define-public r-maps
   (package
     (name "r-maps")