summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 18:23:38 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:53 +0100
commita3b28a85e8a8f0cf22e2474ef7f405ffc52c7e5b (patch)
tree4898ce7313455ab0195d4a12c5576178a9446aa4
parent10e2fc77a7a44c218b4a829388a93843255727f6 (diff)
downloadguix-a3b28a85e8a8f0cf22e2474ef7f405ffc52c7e5b.tar.gz
gnu: Add libkeduvocdocument.
* gnu/packages/education.scm (libkeduvocdocument): New variable.
-rw-r--r--gnu/packages/education.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 25898a0b0e..d28431975d 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1298,3 +1298,36 @@ machine, and more.")
     (description "Commandline client for exercism.io, a free service providing
 mentored learning for programming languages.")
     (license license:expat)))
+
+(define-public libkeduvocdocument
+  (package
+    (name "libkeduvocdocument")
+    (version "20.12.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/libkeduvocdocument-" version ".tar.xz"))
+       (sha256
+        (base32 "0kqnhaabfi91clqg7nlnjcybl5ca0p3ysn5zlwhxz1fcjxm83g4w"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("karchive" ,karchive)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'test-setup
+           (lambda _
+             (setenv "HOME" "/tmp")
+             #t)))))
+    (home-page "https://invent.kde.org/education/libkeduvocdocument")
+    (synopsis "Library to parse, convert, and manipulate KVTML files")
+    (description "Library to parse, convert, and manipulate KVTML files and
+older formats including kvtml1, csv, etc.")
+    (license ;; LGPL for libraries, FDL for documentation
+     (list license:gpl2+ license:fdl1.2+))))