summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:55:55 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:54 +0100
commit3ab0a77b4982422cd2b760f34db6b34d6d52596e (patch)
tree22467b941d4fc601e4a77b784c9a8136fe8fa015
parent015567258d102c4102adfec21b10d10a3210e93c (diff)
downloadguix-3ab0a77b4982422cd2b760f34db6b34d6d52596e.tar.gz
gnu: Add polkit-kde-agent-1.
* gnu/packages/kde-plasma.scm (polkit-kde-agent-1): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 74fdca98b5..b6d179f919 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -48,6 +48,7 @@
   #:use-module (gnu packages password-utils)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages polkit)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
@@ -1657,3 +1658,39 @@ workspace.")
     ;; The archive includes the text of both gpl2 and lgpl3, but the files are
     ;; actually all lgpl3 (according to the metadata.desktop files).
     (license license:lgpl3)))
+
+(define-public polkit-kde-agent-1
+  (package
+    (name "polkit-kde-agent-1")
+    (version "5.19.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/polkit-kde-agent-1-" version ".tar.xz"))
+      (sha256
+       (base32 "0c6v19sp7fcqfbjz8lnb6dr3znwl00q1iv6pakrq09x8a3s2jq87"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kcoreaddons" ,kcoreaddons)
+       ("kcrash" ,kcrash)
+       ("kdbusaddons" ,kdbusaddons)
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("kwindowsystem" ,kwindowsystem)
+       ("polkit-qt5" ,polkit-qt)
+       ("qtbase" ,qtbase)))
+    (home-page "https://invent.kde.org/plasma/polkit-kde-agent-1")
+    (synopsis "PolicyKit authentication agent dialogs for KDE")
+    (description "PolicyKit is an application-level toolkit for defining and
+handling the policy that allows unprivileged processes to speak to privileged
+processes.  It is a framework for centralizing the decision making process
+with respect to granting access to privileged operations (like calling the HAL
+Mount() method) for unprivileged (desktop) applications.
+
+PolicyKit-Kde provides a D-Bus session bus service that is used to bring up
+authentication dialogs used for obtaining privileges.")
+    (license license:gpl2+)))