summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-06-02 18:26:34 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-02 18:55:54 +0200
commit793a48edc0533cacb193afe18c557e6408f3de22 (patch)
treef0609bfc07edd2c2922ca67e5a1c3614508000d6
parentc75a80189fc19f6ff8b4c82d1d1801be6763b6d2 (diff)
downloadguix-793a48edc0533cacb193afe18c557e6408f3de22.tar.gz
gnu: guile-json: Add version 4.0.1.
* gnu/packages/guile.scm (guile-json-4): New variable.
(guile2.2-json): Use it.
-rw-r--r--gnu/packages/guile.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index ef1e19c6b8..c2dc7f6d5f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -554,12 +554,25 @@ specification.  These are the main features:
                      ("guile" ,guile-3.0)))
     (inputs `(("guile" ,guile-3.0)))))
 
-(define-public guile2.2-json
-  (package-for-guile-2.2 guile-json-3))
-
 (define-public guile3.0-json
   (deprecated-package "guile3.0-json" guile-json-3))
 
+(define-public guile-json-4
+  (package
+    (inherit guile-json-3)
+    (name "guile-json")
+    (version "4.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://savannah/guile-json/guile-json-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0f25qak4i57c3x0q9hlrll911l57bb8nz57rjkd02mn2fc2h3730"))))))
+
+(define-public guile2.2-json
+  (package-for-guile-2.2 guile-json-4))
+
 ;; There are two guile-gdbm packages, one using the FFI and one with
 ;; direct C bindings, hence the verbose name.