summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 14:08:22 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:55 +0100
commit9622fa7db712c07b50ab9d0c361a6a6df8b41391 (patch)
treee3d7bad97cd210ccf1d58f3c6830e0d3e10b95a6
parente2b5d0c44308a56928e25da853ed17090463a7e7 (diff)
downloadguix-9622fa7db712c07b50ab9d0c361a6a6df8b41391.tar.gz
gnu: Add powerdevil.
* gnu/packages/kde-plasma.scm (powerdevil): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index c0dba79fb7..50aee9a708 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1759,6 +1759,51 @@ PolicyKit-Kde provides a D-Bus session bus service that is used to bring up
 authentication dialogs used for obtaining privileges.")
     (license license:gpl2+)))
 
+(define-public powerdevil
+  (package
+    (name "powerdevil")
+    (version "5.19.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/powerdevil-" version ".tar.xz"))
+      (sha256
+       (base32 "06mcm361b07i175lnn5prdyrjfm9q9pa9b0rnzv9g04ja0y02pyi"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("bluez-qt" ,bluez-qt)
+       ("eudev", eudev)
+       ("kactivities" ,kactivities)
+       ("kauth" ,kauth)
+       ("kconfig" ,kconfig)
+       ("kcrash" ,kcrash)
+       ("kdbusaddons" ,kdbusaddons)
+       ("kglobalaccel" ,kglobalaccel)
+       ("ki18n" ,ki18n)
+       ("kidletime" ,kidletime)
+       ("kio" ,kio)
+       ("knotifications" ,knotifications)
+       ("knotifyconfig" ,knotifyconfig)
+       ("kwayland" ,kwayland)
+       ("libkscreen" ,libkscreen)
+       ("networkmanager-qt" ,networkmanager-qt)
+       ("plasma-workspace" ,plasma-workspace)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtx11extras" ,qtx11extras)
+       ("solid" ,solid)
+       ("xcb-util-keysyms" ,xcb-util-keysyms)))
+    (home-page "https://invent.kde.org/plasma/powerdevil")
+    (synopsis "Manages the power consumption in Plasma")
+    (description "Power Devil sets and manages the power consumption according
+to your settings.")
+    (license license:gpl2+)))
+
 (define-public sddm-kcm
   (package
     (name "sddm-kcm")