summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:58:45 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:54 +0100
commit9dc52cd32847a8edb5edecac9be8758d403451e5 (patch)
treea2fcfbe07b588c518b85cc505a2225c54d73f86f
parenteffa36c3e550743141fff1cfd0f26b9345dd391f (diff)
downloadguix-9dc52cd32847a8edb5edecac9be8758d403451e5.tar.gz
gnu: Add systemsettings.
* gnu/packages/kde-plasma.scm (systemsettings): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index f4c950331d..b63968bd26 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1729,3 +1729,49 @@ authentication dialogs used for obtaining privileges.")
     (description "This is a System Settings configuration module for
 configuring the SDDM Display Manager.")
     (license license:gpl2+)))
+
+(define-public systemsettings
+  (package
+    (name "systemsettings")
+    (version "5.19.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/systemsettings-" version ".tar.xz"))
+      (sha256
+       (base32 "1y9gkqjn985v51pbi0gg13p2w31bp76wbxnpp9qp47l6ihmxr3xs"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kactivities" ,kactivities)
+       ("kactivities-stats" ,kactivities-stats)
+       ("kcmutils" ,kcmutils)
+       ("kconfig" ,kconfig)
+       ("kcrash" ,kcrash)
+       ("kdbusaddons" ,kdbusaddons)
+       ("kdeclarative" ,kdeclarative)
+       ("kguiaddons" ,kguiaddons)
+       ("khtml" ,khtml)
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("kio" ,kio)
+       ("kitemmodels" ,kitemmodels)
+       ("kitemviews" ,kitemviews)
+       ("kjs" ,kjs)
+       ("kpackage" ,kpackage)
+       ("kparts" ,kparts)
+       ("kservice" ,kservice)
+       ("kwindowsystem" ,kwindowsystem)
+       ("kirigami" ,kirigami)
+       ("kxmlgui" ,kxmlgui)
+       ("plasma-workspace" ,plasma-workspace)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)))
+    (home-page "https://invent.kde.org/plasma/systemsettings")
+    (synopsis "Plasma System Settings")
+    (description "Plasma System Settings is an improved user interface for
+configuring the desktop and other aspects of the system.")
+    (license license:gpl2+)))