summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-27 22:23:06 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:49 +0100
commitcb299fedf3d5c209bb2d8a67493b1a81289b76cc (patch)
tree2a7216230f9c01c5f30651daf7ece67356e6e5b1
parentc9a8ecef835cb6c8085f9f688ecc7f93ed8ac491 (diff)
downloadguix-cb299fedf3d5c209bb2d8a67493b1a81289b76cc.tar.gz
gnu: Add breeze-gtk.
* gnu/packages/kde-plasma.scm (breeze-gtk): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 183aa23a14..82d24e4984 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -49,6 +49,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xdisorg)
@@ -156,6 +157,41 @@ in KDE.  It contains:
 the Plasma Desktop.  Breeze is the default theme for the KDE Plasma desktop.")
     (license license:gpl2+)))
 
+(define-public breeze-gtk
+  (package
+    (name "breeze-gtk")
+    (version "5.19.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/breeze-gtk-" version ".tar.xz"))
+      (sha256
+       (base32 "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
+    ;; TODO: move to gnome.scm?
+    (properties `((upstream-name . "breeze-gtk")))
+    (build-system qt-build-system)
+    (arguments
+     '(#:tests? #f)) ; No 'test' target
+    (native-inputs
+     `(("breeze" ,breeze)
+       ("extra-cmake-modules" ,extra-cmake-modules)
+       ("python" ,python)
+       ("python-pycairo" ,python-pycairo) ; FIXME: needs to be a propagated input?
+       ("sassc" ,sassc)))
+    (inputs
+     `(("qtbase" ,qtbase)))
+    ;; TODO: run-time dependency: GTKEngine (required for GTK 2 theme)
+    (home-page "https://www.kde.org/plasma-desktop")
+    (synopsis "GTK+ theme matching KDE's Breeze theme")
+    (description "A GTK+ theme created to match with the Plasma 5 Breeze
+theme.
+
+To set the theme in Plasma 5, install kde-gtk-config and use System Settings >
+Application Style > GNOME Application Style.  Also make sure to disable “apply
+colors to non-Qt applications“ in System Settings > Colors > Options.")
+    (license license:lgpl2.1+)))
+
 (define-public kdecoration
   (package
     (name "kdecoration")