summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-11-02 10:30:38 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-02 14:59:34 +0100
commite1bd62eb5ce0f2410b2607f157989588791b43e0 (patch)
tree3ca33dc97af4c00cdd7004701950f370e0ee6911
parentc73496f433044a76003b33c3855bb35ecd0df87f (diff)
downloadguix-e1bd62eb5ce0f2410b2607f157989588791b43e0.tar.gz
gnu: slurm: Reintroduce version 19.05.
Partly fixes <https://bugs.gnu.org/44387>.

* gnu/packages/parallel.scm (slurm-19.05): New variable.
-rw-r--r--gnu/packages/parallel.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index b600a1e5b2..d65155bbde 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -190,6 +190,25 @@ by managing a queue of pending work.")
                   license:zlib        ; src/common/strnatcmp.c
                   license:gpl2+))))   ; the rest, often with OpenSSL exception
 
+;; The SLURM client/daemon protocol and file format changes from time to time
+;; in incompatible ways, as noted in
+;; <https://slurm.schedmd.com/troubleshoot.html#network>.  Thus, keep older
+;; releases here.  See also <https://issues.guix.gnu.org/44387>.
+
+(define-public slurm-19.05
+  (package
+    (inherit slurm)
+    (version "19.05.3-2")
+    (source (origin
+              (inherit (package-source slurm))
+              (method url-fetch)
+              (uri (string-append
+                    "https://download.schedmd.com/slurm/slurm-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "0qj4blfymrd2ry2qmb58l3jbr4jwygc3adcfw7my27rippcijlyc"))))))
+
 (define-public slurm-drmaa
   (package
     (name "slurm-drmaa")