summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-08-20 21:27:12 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:55 +0100
commite2b5d0c44308a56928e25da853ed17090463a7e7 (patch)
tree323bae12d7adf71c2565dabda1fa5e9a13c663cf
parent2b3aa28556dfe04c8cca423c079f8493a9f6b74e (diff)
downloadguix-e2b5d0c44308a56928e25da853ed17090463a7e7.tar.gz
gnu: Add kmenuedit.
* gnu/packages/kde-plasma.scm (kmenuedit): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index e96b11fa30..c0dba79fb7 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -445,6 +445,40 @@ all three components can be adjusted together.")
     (description "KHotKeys is core-part of the KDE Plasma desktop.")
     (license license:gpl2+)))
 
+(define-public kmenuedit
+  (package
+    (name "kmenuedit")
+    (version "5.19.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/kmenuedit-" version ".tar.xz"))
+      (sha256
+       (base32 "1xl9k7a3hcmz9yfx7yhy7ff8mcqg62bs4fll8r8nzm04qds1qw7l"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kdbusaddons" ,kdbusaddons)
+       ("kded" ,kded) ; required for property type definitions
+       ("kglobalaccel" ,kglobalaccel)
+       ("khotkeys", khotkeys) ; optional
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("kinit" ,kinit)
+       ("kio" ,kio)
+       ("kxmlgui" ,kxmlgui)
+       ("plasma-framework" ,plasma-framework)
+       ("qtbase" ,qtbase)
+       ("sonnet" ,sonnet)))
+    (home-page "https://invent.kde.org/plasma/kmenuedit")
+    (synopsis "Plasma XDG Menu Editor")
+    (description "This package provides a menu editor which may be used to
+edit the KDE Plasma workspaces menu or any other XDG menu.")
+    (license (list license:gpl2+ license:gpl2))))
+
 (define-public kscreen
   (package
     (name "kscreen")