summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:42:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:53 +0100
commitf15b497d2f919a4ed503f0c754763bc9e9246b87 (patch)
tree49fd7f4ae51f46aec9e195752615e94f345894dd
parentda2d805612ac67db912e8a43a19b966c5c63e5db (diff)
downloadguix-f15b497d2f919a4ed503f0c754763bc9e9246b87.tar.gz
gnu: Add plasma-pa.
* gnu/packages/kde-plasma.scm (plasma-pa): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 110196aefd..dc3e4395ca 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1327,6 +1327,45 @@ In order to start using the widget, look for 'Network Management' in the 'Add
 Widgets' dialog of the Plasma workspace you're using.")
     (license license:gpl3))) ;; KDE e.V.
 
+(define-public plasma-pa
+  (package
+    (name "plasma-pa")
+    (version "5.19.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/plasma-pa-" version ".tar.xz"))
+      (sha256
+       (base32 "1n4imxjfz4zvhgzmsn10kdmxh7cdx8n54n4gwwx5zlvvgjybj3mh"))))
+    ;; TODO: Still some unknown property types, e.g for key
+    ;;  "X-KDE-ParentApp", "X-Plasma-API", "X-DocPath", "X-KDE-Keywords".
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gconf" ,gconf)
+       ("kcmutils" ,kcmutils) ;; required for property type definitions
+       ("kcoreaddons" ,kcoreaddons)
+       ("kdeclarative" ,kdeclarative)
+       ("kglobalaccel" ,kglobalaccel)
+       ("ki18n" ,ki18n)
+       ("knotifications" ,knotifications)
+       ("kwindowsystem" ,kwindowsystem)
+       ("libcanberra" ,libcanberra)
+       ("perl" ,perl) ; for the kconf_update scripts
+       ("plasma-framework" ,plasma-framework)
+       ("pulseaudio" ,pulseaudio)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)))
+    (home-page "https://invent.kde.org/plasma/plasma-pa")
+    (synopsis "Plasma 5 Volume controller")
+    (description "Plasma applet for audio volume management using
+PulseAudio.")
+    (license license:gpl3))) ;; KDE e.V.
+
 (define-public plasma-wayland-protocols
   (package
     (name "plasma-wayland-protocols")