summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-01-07 16:35:59 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-01-07 16:35:59 +0100
commitfc62833b7f394ece1d7867189cd46b5944fa3535 (patch)
tree53528c1e079568033612aaa585156fb209e71f31
parentcf7035dea00c7c1b7238bc8ff3f7b69cf892e3f9 (diff)
downloadguix-fc62833b7f394ece1d7867189cd46b5944fa3535.tar.gz
gnu: emacs-sly-stepper: Update to 20200106.
* gnu/packages/emacs-xyz.scm (emacs-sly-stepper): Update to 20200106.
[arguments]: Remove convoluted part of the workaround to load agnostic-lizard
now that upstream has cleaned up the code.
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 6 insertions, 13 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 689d3dd54b..0923598156 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9736,7 +9736,7 @@ inside the source file.")
       (license license:gpl3+))))
 
 (define-public emacs-sly-stepper
-  (let ((commit "cd7fd00f9a701246e2a9ba8c37166dcae2fde04e"))
+  (let ((commit "ec3c0a7f3c8b82926882e5fcfdacf67b86d989f8"))
     (package
       (name "emacs-sly-stepper")
       (version (git-version "0.0.0" "1" commit))
@@ -9750,7 +9750,7 @@ inside the source file.")
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "09ll9dv8fd5dgnki82hcd48nm4qdzzn8wpva0zzr69zkjwzf9v25"))))
+           "1hxniaxifdw3m4y4yssgy22xcmmf558wx7rpz66wy5hwybjslf7b"))))
       (build-system emacs-build-system)
       (inputs
        `(("cl-agnostic-lizard" ,cl-agnostic-lizard)))
@@ -9780,18 +9780,11 @@ inside the source file.")
                             "/share/common-lisp/systems/agnostic-lizard.asd")))
                  ;; agnostic-lizard is found at runtime.
                  (substitute* file
-                   (("\\(funcall \\(read-from-string \"asdf:load-system\"\\)")
+                   (("\\(require :asdf\\)")
                     (string-append
-                     "(funcall (read-from-string \"asdf:load-asd\") \""
-                     asd
-                     "\")\n     (funcall (read-from-string \"asdf:load-system\")"))
-                   ;; Upstream mistakenly requires Quicklisp.  See
-                   ;; https://github.com/joaotavora/sly-stepper/issues/2.
-                   (("\\(funcall \\(read-from-string \"ql:quickload\"\\)")
-                    (string-append
-                     "(ignore-errors (funcall (read-from-string \"ql:quickload\") "
-                     ":agnostic-lizard))"))
-                   (("                    :agnostic-lizard\\)") ""))))))))
+                     "(require :asdf)\n"
+                     "     (funcall (read-from-string \"asdf:load-asd\")\n"
+                     "              \"" asd "\")\n")))))))))
       (synopsis "Portable Common Lisp stepper interface for Emacs")
       (description
        "This package features a new, portable, visual stepping facility for