summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-14 19:48:45 +0200
committerDavid Craven <david@craven.ch>2016-08-15 02:24:10 +0200
commit273f1c05d8b6940c795fa3ceab31c6d48222ff92 (patch)
tree8f9c5e4ec4e99744c063f1b9e7a376f03dd38fff
parentd4db0612dcfb3e19fc2be7447b1ee242819c0df8 (diff)
downloadguix-273f1c05d8b6940c795fa3ceab31c6d48222ff92.tar.gz
gnu: usbredir: Add git commit to version.
* gnu/packages/spice.scm (usbredir)[version]: Add commit and revision to version
  string.
-rw-r--r--gnu/packages/spice.scm78
1 files changed, 41 insertions, 37 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 67e493a439..870278c3ea 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -44,49 +44,53 @@
   #:use-module (guix utils))
 
 (define-public usbredir
-  (package
-    (name "usbredir")
-    (version "0.7.1")
-    ;(source (origin
-    ;          (method url-fetch)
-    ;          (uri (string-append
-    ;            "http://spice-space.org/download/usbredir/"
-    ;            "usbredir-" version ".tar.bz2"))
-    ;          (sha256
-    ;           (base32
-    ;            "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
-    ; FIXME: usbredir 0.7.1 release doesn't build on 32 bit systems.
-    ;        issue is fixed in HEAD
-    ;        remove 'autogen phase and autoconf, automake, libtool inputs
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                      (url "http://cgit.freedesktop.org/spice/usbredir")
-                      (commit "ac80a5971c6318d73d5fba4b5f13d3a9389558c9")))
-              (sha256
-               (base32
-                "052fywgi72j68dr5ybldncg4vk8iqfrh58la7iazyxxpph9aag1g"))))
-    (build-system gnu-build-system)
-    (propagated-inputs
-      `(("libusb" ,libusb)))
-    (native-inputs
-      `(("pkg-config" ,pkg-config)
-        ("autoconf" ,autoconf)
-        ("automake" ,automake)
-        ("libtool" ,libtool)))
+  (let ((commit "ac80a5971c6318d73d5fba4b5f13d3a9389558c9")
+        (revision "1"))          ;Guix package revision
+    (package
+      (name "usbredir")
+      (version (string-append "0.7.1-" revision "."
+                              (string-take commit 7)))
+      ;(version "0.7.1")
+      ;(source (origin
+      ;          (method url-fetch)
+      ;          (uri (string-append
+      ;            "http://spice-space.org/download/usbredir/"
+      ;            "usbredir-" version ".tar.bz2"))
+      ;          (sha256
+      ;           (base32
+      ;            "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
+      ; FIXME: usbredir 0.7.1 release doesn't build on 32 bit systems.
+      ;        issue is fixed in HEAD
+      ;        remove 'autogen phase and autoconf, automake, libtool inputs
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                        (url "http://cgit.freedesktop.org/spice/usbredir")
+                        (commit commit)))
+                (sha256
+                 (base32
+                  "052fywgi72j68dr5ybldncg4vk8iqfrh58la7iazyxxpph9aag1g"))))
+      (build-system gnu-build-system)
+      (propagated-inputs
+        `(("libusb" ,libusb)))
+      (native-inputs
+        `(("pkg-config" ,pkg-config)
+          ("autoconf" ,autoconf)
+          ("automake" ,automake)
+          ("libtool" ,libtool)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'autogen
            (lambda* _
              (system* "sh" "autogen.sh"))))))
-    (synopsis "Tools for sending USB device traffic over a network")
-    (description "Usbredir is a network protocol for sending USB device traffic
-over a network connection.  It can be used to redirect traffic from a USB device
-to a different (virtual) machine than the one to which the USB device is
-attached.")
-    (home-page "http://www.spice-space.org")
-    (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
+      (synopsis "Tools for sending USB device traffic over a network")
+      (description "Usbredir is a network protocol for sending USB device traffic
+  over a network connection.  It can be used to redirect traffic from a USB device
+  to a different (virtual) machine than the one to which the USB device is
+  attached.")
+      (home-page "http://www.spice-space.org")
+      (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+)))))
 
 (define-public virglrenderer
   (package