summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:52:43 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit39e547f219c68eec7e144dbf7e062511d347c94d (patch)
treed1f53dcb3033b1ecc74682ac31059d3163fcb534
parent9fd502cee54d98dd5d9ba5fbb2ad7ad7f4f936d8 (diff)
downloadguix-39e547f219c68eec7e144dbf7e062511d347c94d.tar.gz
gnu: kde-frameworks: Add sonnet.
* gnu/packages/kde-frameworks.scm (sonnet): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index c0914e39d6..7bd44ec5d7 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -942,3 +942,29 @@ which are used in DBus communication.")
 querying and interacting with hardware independently of the underlying operating
 system.")
     (license license:lgpl2.1+)))
+
+(define-public sonnet
+  (package
+    (name "sonnet")
+    (version "5.24.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/frameworks/"
+                            (version-major+minor version) "/"
+                            name "-" version ".tar.xz"))
+        (sha256
+         (base32
+          "152xz7fb1iwhb5w1n4xqvc648iaxi0inrl4kavxcsir61das1xyl"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("qtbase" ,qtbase)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Multi-language spell checker")
+    (description "Sonnet is a plugin-based spell checking library for Qt-based
+applications.  It supports several different plugins, including HSpell, Enchant,
+ASpell and HUNSPELL.")
+    (license license:lgpl2.1+)))