summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-14 19:49:52 +0200
committerDavid Craven <david@craven.ch>2016-08-15 02:24:11 +0200
commit8cce8797be11a0709b982ca540c6f9c7597e8c08 (patch)
treec08621ed547d0b07890e4c384135f96b93f01241
parent273f1c05d8b6940c795fa3ceab31c6d48222ff92 (diff)
downloadguix-8cce8797be11a0709b982ca540c6f9c7597e8c08.tar.gz
gnu: usbredir: Invoke autoreconf directly.
* gnu/packages/spice.scm (usbredir)[arguments]: Invoke autoreconf directly.
-rw-r--r--gnu/packages/spice.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 870278c3ea..3e6366e6c0 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -78,12 +78,12 @@
           ("autoconf" ,autoconf)
           ("automake" ,automake)
           ("libtool" ,libtool)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'autogen
-           (lambda* _
-             (system* "sh" "autogen.sh"))))))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'autogen
+             (lambda _
+               (zero? (system* "autoreconf" "-vfi")))))))
       (synopsis "Tools for sending USB device traffic over a network")
       (description "Usbredir is a network protocol for sending USB device traffic
   over a network connection.  It can be used to redirect traffic from a USB device