summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-08-03 00:22:08 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-08-03 04:54:24 +0200
commit9a57d3e6a19b56d9c4c7917c401878c15866be0c (patch)
tree7e886c0fd1c5a3abc8498d7408a89154e6244a46
parent618977ae38402af3118ff393492d2883f5894c4a (diff)
downloadguix-9a57d3e6a19b56d9c4c7917c401878c15866be0c.tar.gz
gnu: rc: Move to shells.scm.
* gnu/packages/rc.scm (rc): Move from here ...
* gnu/packages/shells.scm (rc): ... to here.
* gnu/packages/rc.scm: Delete file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Remove rc.scm.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/rc.scm72
-rw-r--r--gnu/packages/shells.scm51
3 files changed, 51 insertions, 73 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 442bd791a2..cff257646a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -291,7 +291,6 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/ragel.scm			\
   %D%/packages/rails.scm			\
   %D%/packages/ratpoison.scm			\
-  %D%/packages/rc.scm				\
   %D%/packages/rdesktop.scm			\
   %D%/packages/rdf.scm				\
   %D%/packages/readline.scm			\
diff --git a/gnu/packages/rc.scm b/gnu/packages/rc.scm
deleted file mode 100644
index d3edf9e997..0000000000
--- a/gnu/packages/rc.scm
+++ /dev/null
@@ -1,72 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages rc)
-  #:use-module (gnu packages autotools)
-  #:use-module (gnu packages perl)
-  #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages readline)
-  #:use-module (guix build-system gnu)
-  #:use-module (guix git-download)
-  #:use-module (guix licenses)
-  #:use-module (guix packages))
-
-(define-public rc
-  (package
-    (name "rc")
-    (version "1.7.4")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "git://github.com/rakitzis/rc.git")
-                    ;; commit name 'release: rc-1.7.4'
-                    (commit "c884da53a7c885d46ace2b92de78946855b18e92")))
-              (sha256
-               (base32
-                "00mgzvrrh9w96xa85g4gjbsvq02f08k4jwjcdnxq7kyh5xgiw95l"))
-              (file-name (string-append name "-" version "-checkout"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:configure-flags
-       '("--with-edit=gnu")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after
-          'unpack 'autoreconf
-          (lambda _ (zero? (system* "autoreconf" "-vfi"))))
-         (add-before
-          'autoreconf 'patch-trip.rc
-          (lambda _
-            (substitute* "trip.rc"
-              (("/bin/pwd") (which "pwd"))
-              (("/bin/sh")  (which "sh"))
-              (("/bin/rm")  (which "rm"))
-              (("/bin\\)")  (string-append (dirname (which "rm")) ")")))
-            #t)))))
-    (inputs `(("readline" ,readline)
-              ("perl" ,perl)))
-    (native-inputs `(("autoconf" ,autoconf)
-                     ("automake" ,automake)
-                     ("libtool" ,libtool)
-                     ("pkg-config" ,pkg-config)))
-    (synopsis "Alternative implementation of the rc shell by Byron Rakitzis")
-    (description
-     "This is a reimplementation by Byron Rakitzis of the Plan 9 shell.  It
-has a small feature set similar to a traditional Bourne shell.")
-    (home-page "http://github.com/rakitzis/rc")
-    (license zlib)))
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index cc0aa7da44..cc0a8a5adb 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015 David Thompson <davet@gnu.org>
+;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
 ;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -18,12 +19,17 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages shells)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages libedit)
   #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages readline)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix licenses)
   #:use-module (guix packages))
 
@@ -100,3 +106,48 @@ terminal handling based on terminfo, an easy to search history, and syntax
 highlighting.")
     (home-page "https://fishshell.com/")
     (license gpl2)))
+
+(define-public rc
+  (package
+    (name "rc")
+    (version "1.7.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "git://github.com/rakitzis/rc.git")
+                    ;; commit name 'release: rc-1.7.4'
+                    (commit "c884da53a7c885d46ace2b92de78946855b18e92")))
+              (sha256
+               (base32
+                "00mgzvrrh9w96xa85g4gjbsvq02f08k4jwjcdnxq7kyh5xgiw95l"))
+              (file-name (string-append name "-" version "-checkout"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       '("--with-edit=gnu")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after
+          'unpack 'autoreconf
+          (lambda _ (zero? (system* "autoreconf" "-vfi"))))
+         (add-before
+          'autoreconf 'patch-trip.rc
+          (lambda _
+            (substitute* "trip.rc"
+              (("/bin/pwd") (which "pwd"))
+              (("/bin/sh")  (which "sh"))
+              (("/bin/rm")  (which "rm"))
+              (("/bin\\)")  (string-append (dirname (which "rm")) ")")))
+            #t)))))
+    (inputs `(("readline" ,readline)
+              ("perl" ,perl)))
+    (native-inputs `(("autoconf" ,autoconf)
+                     ("automake" ,automake)
+                     ("libtool" ,libtool)
+                     ("pkg-config" ,pkg-config)))
+    (synopsis "Alternative implementation of the rc shell by Byron Rakitzis")
+    (description
+     "This is a reimplementation by Byron Rakitzis of the Plan 9 shell.  It
+has a small feature set similar to a traditional Bourne shell.")
+    (home-page "http://github.com/rakitzis/rc")
+    (license zlib)))