summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-11 17:07:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-11 22:44:07 +0300
commitb92f651be82f0398ee6982f1274e9047a3ed16d5 (patch)
tree7d257bf90e61b1f16ef5f8c93af2ae265d0a4818
parentdd22efef0a8d625786209e3cf86c255d66bc6317 (diff)
downloadguix-b92f651be82f0398ee6982f1274e9047a3ed16d5.tar.gz
gnu: python-cython: Use 'modify-phases'.
* gnu/packages/python.scm (python-cython)[arguments]: Use 'modify-phases'.
-rw-r--r--gnu/packages/python.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 76e3ff2d18..9d5ff749e7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3014,14 +3014,12 @@ is designed to have a low barrier to entry.")
      `(("python" ,python)))
     (arguments
      `(#:phases
-       (alist-cons-before
-        'check 'set-HOME
-        ;; some tests require access to "$HOME/.cython"
-        (lambda* _ (setenv "HOME" "/tmp"))
-        (alist-replace
-         'check
-         (lambda _ (zero? (system* "python" "runtests.py" "-vv")))
-         %standard-phases))))
+       (modify-phases %standard-phases
+         (add-before 'check 'set-HOME
+           ;; some tests require access to "$HOME/.cython"
+           (lambda _ (setenv "HOME" "/tmp")))
+         (replace 'check
+           (lambda _ (zero? (system* "python" "runtests.py" "-vv")))))))
     (home-page "http://cython.org/")
     (synopsis "C extensions for Python")
     (description "Cython is an optimising static compiler for both the Python