summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-07 13:06:00 -0400
committerMark H Weaver <mhw@netris.org>2015-07-07 13:09:36 -0400
commite0884109847787f1e24258829a375dab9e40485b (patch)
treed0085b5207373602cf19974c6966748e69475515
parent23da88f61e82e2b32d6dedb3af467f665cd03bf5 (diff)
downloadguix-e0884109847787f1e24258829a375dab9e40485b.tar.gz
gnu: Add libmpeg2.
* gnu/packages/video.scm (libmpeg2): New variable.
-rw-r--r--gnu/packages/video.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 259e858e7d..456178565e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -161,6 +161,33 @@ A/52 standard is used in a variety of applications, including digital
 television and DVD.  It is also known as AC-3.")
     (license license:gpl2+)))
 
+(define-public libmpeg2
+  (package
+    (name "libmpeg2")
+    (version "0.5.1")
+    (source (origin
+              (method url-fetch)
+              ;; A mirror://sourceforge URI doesn't work, presumably
+              ;; because the SourceForge project is misconfigured.
+              (uri (string-append "http://libmpeg2.sourceforge.net/files/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1m3i322n2fwgrvbs1yck7g5md1dbg22bhq5xdqmjpz5m7j4jxqny"))))
+    (inputs
+     `(("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libxv" ,libxv)
+       ("libsm" ,libsm)
+       ("libice" ,libice)
+       ("sdl" ,sdl)))
+    (build-system gnu-build-system)
+    (home-page "http://libmpeg2.sourceforge.net/")
+    (synopsis "MPEG1 and MPEG2 video decoder library")
+    (description
+     "libmpeg2 is a library which can decode MPEG1 and MPEG2 video streams.")
+    (license license:gpl2+)))
+
 (define-public libass
   (package
     (name "libass")