summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:39:34 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commitf3f250ad32cfd75e242ca6e5cf091bcab96c9c8f (patch)
tree327b6bbbf5748a29b0560c64ed64950010d36f2a
parent594c7f35bc302181cad8fc4baeb10e043e3f15d3 (diff)
downloadguix-f3f250ad32cfd75e242ca6e5cf091bcab96c9c8f.tar.gz
gnu: kde-frameworks: Add kcoreaddons.
* gnu/packages/kde-frameworks.scm (kcoreaddons): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index b4d4dc1f7d..390c3e589a 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -349,6 +349,44 @@ propagate their changes to their respective configuration files.")
                    license:lgpl3+ license:gpl1 ; licende:mit-olif
                    license:bsd-2 license:bsd-3))))
 
+(define-public kcoreaddons
+  (package
+    (name "kcoreaddons")
+    (version "5.24.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/frameworks/"
+                            (version-major+minor version) "/"
+                            name "-" version ".tar.xz"))
+        (sha256
+         (base32
+          "06sx7by3nvaridnavj5p0bxv4nh47n708jlacfw8ydaikmd9i03h"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("qttools" ,qttools)
+       ("xorg-server" ,xorg-server))) ; for the tests
+    (inputs
+     `(("qtbase" ,qtbase)))
+    (arguments
+     `(#:tests? #f ; FIXME: Test failure caused by stout/stderr being interleaved.
+       #:phases
+        (modify-phases %standard-phases
+          (add-before 'check 'check-setup
+            (lambda* _
+              (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug output
+              (setenv "HOME" (getcwd))
+              (setenv "TMPDIR" (getcwd)))))))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Qt addon library with a collection of non-GUI utilities")
+    (description "KCoreAddons provides classes built on top of QtCore to
+perform various tasks such as manipulating mime types, autosaving files,
+creating backup files, generating random sequences, performing text
+manipulations such as macro replacement, accessing user information and
+many more.")
+    (license (list license:lgpl2.0+ license:lgpl2.1+))))
+
 (define-public kwindowsystem
   (package
     (name "kwindowsystem")