summary refs log tree commit diff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-07-23 12:36:37 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-08-01 12:37:13 +0200
commit4aadb1dff7995d96261607d5b032ebc9656516a4 (patch)
treedc188bd91e1f7eef5c32f62746820c28f7899d09
parent6d992d078e1994265d921ef4e301b5722c6503c6 (diff)
downloadguix-4aadb1dff7995d96261607d5b032ebc9656516a4.tar.gz
gnu: Add python-terminado.
* gnu/packages/python.scm (python-terminado, python2-terminado): New
  variables.
-rw-r--r--gnu/packages/python.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c97cf9df06..96fe83127a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4604,3 +4604,45 @@ pseudo terminal (pty), and interact with both the process and its pty.")
 
 (define-public python2-ptyprocess
   (package-with-python2 python-ptyprocess))
+
+(define-public python-terminado
+  (package
+    (name "python-terminado")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/t/terminado/terminado-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1dkmp1n8dj5v1jl9mfrq8lwyc7dsfrvcmz2bgkpg315sy7pr7s33"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-tornado" ,python-tornado)
+       ("python-ptyprocess" ,python-ptyprocess)))
+    (inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-nose" ,python-nose)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+                  (lambda _
+                    (zero? (system* "nosetests")))))))
+    (home-page "https://github.com/takluyver/terminado")
+    (synopsis "Terminals served to term.js using Tornado websockets")
+    (description "This package provides a Tornado websocket backend for the
+term.js Javascript terminal emulator library.")
+    (license bsd-2)))
+
+(define-public python2-terminado
+  (let ((terminado (package-with-python2 python-terminado)))
+    (package (inherit terminado)
+             (propagated-inputs
+              `(("python2-tornado" ,python2-tornado)
+                ("python2-backport-ssl-match-hostname"
+                 ,python2-backport-ssl-match-hostname)
+                ,@(alist-delete "python-tornado"
+                                (package-propagated-inputs terminado)))))))