summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-25 11:01:56 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-25 11:01:56 -0800
commita8f20f63dce1f41126bbc0fdbe6a3b1bf28fb69d (patch)
tree4a922c2457ecae8e4e33edab29247378cdd8b0af
parentc4a7904c21c854d5f1d49eeecf76bbefe087a893 (diff)
downloadguix-a8f20f63dce1f41126bbc0fdbe6a3b1bf28fb69d.tar.gz
gnu: Add python-pastescript.
* gnu/packages/python.scm (python-pastescript, python2-pastescript):
  New variables.
-rw-r--r--gnu/packages/python.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 03b2778b23..1b274a3130 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7822,6 +7822,44 @@ follows ideas flowing from WSGI (Web Standard Gateway Interface).")
        `(#:tests? #t
          ,@(package-arguments paste))))))
 
+(define-public python-pastescript
+  (package
+    (name "python-pastescript")
+    (version "2.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PasteScript" version))
+       (sha256
+        (base32
+         "1h3nnhn45kf4pbcv669ik4faw04j58k8vbj1hwrc532k0nc28gy0"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(;; Uses pkg_resources provided by setuptools internally.
+       ("python-setuptools" ,python-setuptools)
+       ("python-paste" ,python-paste)
+       ("python-pastedeploy" ,python-pastedeploy)))
+    (home-page "http://pythonpaste.org/script/")
+    (arguments
+     '(;; Unfortunately, this requires the latest unittest2,
+       ;; but that requires traceback2 which requires linecache2 which requires
+       ;; unittest2.  So we're skipping tests for now.
+       ;; (Note: Apparently linetest2 only needs unittest2 for its tests,
+       ;; so in theory we could get around this situation somehow.)
+       #:tests? #f))
+    (synopsis
+     "Pluggable command line tool for serving web applications and more")
+    (description
+     "PasteScript is a plugin-friendly command line tool which provides a
+variety of features, from launching web applications to bootstrapping project
+layouts.")
+    (license license:expat)))
+
+(define-public python2-pastescript
+  (package-with-python2 python-pastescript))
+
 (define-public python-pyquery
   (package
     (name "python-pyquery")