summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-16 17:20:32 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-24 17:26:39 +0100
commite761beb9a9197c6559c8acb48d2f123207388903 (patch)
tree3ef1f23d848dd500b83e06140a0b680992aadd30
parent16c53a1e268a41d2d8c329b193d8bfb299490962 (diff)
downloadguix-e761beb9a9197c6559c8acb48d2f123207388903.tar.gz
gnu: Add r-org-mm-eg-db.
* gnu/packages/bioinformatics.scm (r-org-mm-eg-db): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4f097f6d90..64a398f52b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4335,6 +4335,32 @@ annotations for the genome of the model worm Caenorhabditis elegans.")
 annotations for the genome of the model fruit fly Drosophila melanogaster.")
     (license license:artistic2.0)))
 
+(define-public r-org-mm-eg-db
+  (package
+    (name "r-org-mm-eg-db")
+    (version "3.2.3")
+    (source (origin
+              (method url-fetch)
+              ;; We cannot use bioconductor-uri here because this tarball is
+              ;; located under "data/annotation/" instead of "bioc/".
+              (uri (string-append "http://www.bioconductor.org/packages/"
+                                  "release/data/annotation/src/contrib/"
+                                  "org.Mm.eg.db_" version ".tar.gz"))
+              (sha256
+               (base32
+                "0wh1pm3npdg7070875kfgiid3bqkz3q7rq6snhk6bxfvph00298y"))))
+    (properties
+     `((upstream-name . "org.Mm.eg.db")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)))
+    (home-page "http://www.bioconductor.org/packages/org.Mm.eg.db/")
+    (synopsis "Genome wide annotation for Mouse")
+    (description
+     "This package provides mappings from Entrez gene identifiers to various
+annotations for the genome of the model mouse Mus musculus.")
+    (license license:artistic2.0)))
+
 (define-public r-qtl
  (package
   (name "r-qtl")