summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-24 11:24:38 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-25 10:51:52 +0000
commit0458cbd84c03068241dfaf293b0594ec07dc2019 (patch)
treefa22a558558a148c833cbc25a87f14e91fbe7a02
parent3271fa1f402e497ff1de9cc2dbc2b09e1a32078f (diff)
downloadguix-0458cbd84c03068241dfaf293b0594ec07dc2019.tar.gz
gnu: Add python-mpl-animators.
* gnu/packages/astronomy.scm (python-mpl-animators): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fb45a83b34..e9409cbade 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1202,6 +1202,32 @@ for a table giving the position of a planet, asteroid, or comet for a series
 of dates.")
     (license license:expat)))
 
+(define-public python-mpl-animators
+  (package
+    (name "python-mpl-animators")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mpl_animators" version))
+       (sha256
+        (base32 "12kjmj7rn3pk9ly82h5s5hn0kl3kxkr7bgkz9zr9k59pir8z1r8b"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-pytest
+           python-pytest-mpl
+           python-setuptools-scm))
+    (propagated-inputs
+     (list python-astropy
+           python-matplotlib
+           python-numpy))
+    (home-page "https://sunpy.org")
+    (synopsis "Interactive animations with matplotlib")
+    (description
+     "The @code{mpl_animators} package provides a set of classes which allow
+the easy construction of interactive matplotlib widget based animations.")
+    (license license:bsd-3)))
+
 (define-public python-photutils
   (package
     (name "python-photutils")