summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-24 11:24:39 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-25 10:51:52 +0000
commit0575012803683ebacd43029530683af7bdf791f9 (patch)
tree61fd6aff001120804f22416fea659a38c7c61789
parent0458cbd84c03068241dfaf293b0594ec07dc2019 (diff)
downloadguix-0575012803683ebacd43029530683af7bdf791f9.tar.gz
gnu: Add python-hvpy.
* gnu/packages/astronomy.scm (python-hvpy): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e9409cbade..492b871e12 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1202,6 +1202,27 @@ for a table giving the position of a planet, asteroid, or comet for a series
 of dates.")
     (license license:expat)))
 
+(define-public python-hvpy
+  (package
+    (name "python-hvpy")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hvpy" version))
+       (sha256
+        (base32 "0r0asyflz2sw9zn5vgs138nh81m0rbwbakmrncbc1ghdr3g6jahv"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f)) ; Requires HTTP(S) access to api.beta.helioviewer.org
+    (propagated-inputs (list python-pydantic python-requests))
+    (native-inputs (list python-pytest python-pytest-astropy))
+    (home-page "https://helioviewer.org/")
+    (synopsis "Helioviewer Python API Wrapper")
+    (description "@code{hvpy} is a Python API wrapper around the formal
+@url{Helioviewer API, https://api.helioviewer.org/docs/v2/}.")
+    (license license:bsd-2)))
+
 (define-public python-mpl-animators
   (package
     (name "python-mpl-animators")