summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-24 17:59:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-24 18:02:15 +0100
commit139da51753717a06692bd87a754f54b4e60f4fcd (patch)
tree70f3dabd7e5d28a32c5eafb5c0dc3ea3e9b6d365
parent90d8ac279fcffe12969e0bdd43a07363c212942e (diff)
downloadguix-139da51753717a06692bd87a754f54b4e60f4fcd.tar.gz
gnu: Add r-mia.
* gnu/packages/bioconductor.scm (r-mia): New variable.
-rw-r--r--gnu/packages/bioconductor.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 17d5195ce5..0d4110bc20 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10027,6 +10027,54 @@ to identify differentially methylated regions in epigenetic epidemiology
 studies.")
     (license license:artistic2.0)))
 
+(define-public r-mia
+  (package
+    (name "r-mia")
+    (version "1.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "mia" version))
+              (sha256
+               (base32
+                "0yz88ggv6d5rccdwzixwg9y1bc4xysazlmv1ph88wxs8r6fcmync"))))
+    (properties `((upstream-name . "mia")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ape
+           r-biocgenerics
+           r-biocparallel
+           r-biostrings
+           r-decipher
+           r-decontam
+           r-delayedarray
+           r-delayedmatrixstats
+           r-dirichletmultinomial
+           r-dplyr
+           r-iranges
+           r-mass
+           r-multiassayexperiment
+           r-rlang
+           r-s4vectors
+           r-scater
+           r-scuttle
+           r-singlecellexperiment
+           r-summarizedexperiment
+           r-tibble
+           r-tidyr
+           r-treesummarizedexperiment
+           r-vegan))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/microbiome/mia")
+    (synopsis "Microbiome analysis")
+    (description
+     "The mia package implements tools for microbiome analysis based on the
+@code{SummarizedExperiment}, @code{SingleCellExperiment} and
+@code{TreeSummarizedExperiment} infrastructure.  Data wrangling and analysis
+in the context of taxonomic data is the main scope.  Additional functions for
+common task are implemented such as community indices calculation and
+summarization.")
+    (license license:artistic2.0)))
+
 (define-public r-microbiome
   (package
     (name "r-microbiome")