summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-04 22:35:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-04 22:36:01 +0300
commit77bb6c227b441277e48d6e2071cca3b801f53374 (patch)
treed981d4afe812c6de0941b3ae700c9dbefa4526fb
parentb82c63d013758fe0e0416b9ff36cb2de18cafa1e (diff)
downloadguix-77bb6c227b441277e48d6e2071cca3b801f53374.tar.gz
gnu: gpm: Fix build.
* gnu/packages/linux.scm (gpm)[arguments]: Patch autogen.sh shebang
during the 'boottstrap phase.
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3975c94612..245b36f2c6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3126,6 +3126,8 @@ write access to exFAT devices.")
                     (lambda _
                       ;; The tarball was not generated with 'make dist' so we
                       ;; need to bootstrap things ourselves.
+                      (substitute* "autogen.sh"
+                        (("/bin/sh") (which "sh")))
                       (and (zero? (system* "./autogen.sh"))
                            (begin
                              (patch-makefile-SHELL "Makefile.include.in")