summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-19 22:42:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-11-24 18:02:15 +0100
commit8d3bd8e4b08fef0ea7fac48296191d3e6e342e9c (patch)
treec5fa5771971e241d385d4565cd3a15e9b3660630
parenta8c36bf8c49d1f790d4132a47e95972bba793c89 (diff)
downloadguix-8d3bd8e4b08fef0ea7fac48296191d3e6e342e9c.tar.gz
gnu: Add r-ancombc.
* gnu/packages/bioconductor.scm (r-ancombc): New variable.
-rw-r--r--gnu/packages/bioconductor.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 61f312e17f..d9303b5873 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2284,6 +2284,52 @@ of Medical Research.  The goal is to provide a standard library for quantitative
 analysis, modelling, and visualization of spike-in controls.")
     (license license:bsd-3)))
 
+(define-public r-ancombc
+  (package
+    (name "r-ancombc")
+    (version "1.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "ANCOMBC" version))
+              (sha256
+               (base32
+                "1p9yryv85qk7m3hbflmpdffd3azpsifcw54x1rp8sb67yjmq3whq"))))
+    (properties `((upstream-name . "ANCOMBC")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-desctools
+           r-doparallel
+           r-dorng
+           r-dplyr
+           r-energy
+           r-foreach
+           r-hmisc
+           r-magrittr
+           r-mass
+           r-microbiome
+           r-nlme
+           r-nloptr
+           r-phyloseq
+           r-rdpack
+           r-rlang
+           r-tibble
+           r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/FrederickHuangLin/ANCOMBC")
+    (synopsis "Analysis of compositions of microbiomes with bias correction")
+    (description
+     "@code{ANCOMBC} is a package containing @dfn{differential abundance} (DA)
+and correlation analyses for microbiome data.  Specifically, the package
+includes @dfn{Analysis of Compositions of Microbiomes with Bias
+Correction}(ANCOM-BC) and @dfn{Analysis of Composition of Microbiomes} (ANCOM)
+for DA analysis, and @dfn{Sparse Estimation of Correlations among
+Microbiomes} (SECOM) for correlation analysis.  Microbiome data are typically
+subject to two sources of biases: unequal sampling fractions (sample-specific
+biases) and differential sequencing efficiencies (taxon-specific biases).
+Methodologies included in the @code{ANCOMBC} package were designed to correct
+these biases and construct statistically consistent estimators.")
+    (license license:artistic2.0)))
+
 (define-public r-aldex2
   (package
     (name "r-aldex2")