summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-24 17:28:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-24 18:02:15 +0100
commit90d8ac279fcffe12969e0bdd43a07363c212942e (patch)
tree6aa1197e30b2dc1de24650fd6d202bd66190e60c
parentefb965a4fabb09d0a4af7a9ff176d4af509ee134 (diff)
downloadguix-90d8ac279fcffe12969e0bdd43a07363c212942e.tar.gz
gnu: Add r-treesummarizedexperiment.
* gnu/packages/bioconductor.scm (r-treesummarizedexperiment): New variable.
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d9303b5873..17d5195ce5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8989,6 +8989,39 @@ heterogeneous associated data to a single tree file and can be served as a
 platform for merging tree with associated data and converting file formats.")
     (license license:artistic2.0)))
 
+(define-public r-treesummarizedexperiment
+  (package
+    (name "r-treesummarizedexperiment")
+    (version "2.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "TreeSummarizedExperiment" version))
+              (sha256
+               (base32
+                "136zgpn1l059i64gj6iappr6nz42z4wbxlg3zpc5npwkqrz3val2"))))
+    (properties `((upstream-name . "TreeSummarizedExperiment")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ape
+           r-biocgenerics
+           r-biocparallel
+           r-biostrings
+           r-dplyr
+           r-iranges
+           r-rlang
+           r-s4vectors
+           r-singlecellexperiment
+           r-summarizedexperiment
+           r-treeio))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/TreeSummarizedExperiment")
+    (synopsis "S4 class for data with tree structures")
+    (description
+     "@code{TreeSummarizedExperiment} extends @code{SingleCellExperiment} to
+include hierarchical information on the rows or columns of the rectangular
+data.")
+    (license license:gpl2+)))
+
 (define-public r-ggtree
   (package
     (name "r-ggtree")