summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-24 10:17:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-24 22:22:39 +0200
commitb3beeaa30981e49070ff28434b69aa234069bd2d (patch)
tree75cc6d1376948b5f8efda6c5782d573946c7651f
parent255450bed2b24b9dd21745e2675aa0ecf38a2a79 (diff)
downloadguix-b3beeaa30981e49070ff28434b69aa234069bd2d.tar.gz
gnu: arm-trusted-firmware: Remove blobs in a snippet.
* gnu/packages/firmware.scm (make-arm-trusted-firmware)[source]: Add
snippet to remove binary blobs.
[arguments]: Remove related phase.
-rw-r--r--gnu/packages/firmware.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 9f6c957113..e9bb3ed450 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -656,18 +656,19 @@ Virtual Machines.  OVMF contains a sample UEFI firmware for QEMU and KVM.")
         (file-name (git-file-name "arm-trusted-firmware" version))
        (sha256
         (base32
-         "0grq3fgxi9xhcljnhwlxjvdghyz15gaq50raw41xy4lm8rkmnzp3"))))
+         "0grq3fgxi9xhcljnhwlxjvdghyz15gaq50raw41xy4lm8rkmnzp3"))
+       (snippet
+        #~(begin
+            (use-modules (guix build utils))
+            ;; Remove binary blobs which do not contain source or proper license.
+            (for-each (lambda (file)
+                        (delete-file file))
+                      (find-files "." "\\.bin$"))))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (delete 'configure) ; no configure script
-         ;; Remove binary blobs which do not contain source or proper license.
-         (add-after 'unpack 'remove-binary-blobs
-           (lambda _
-             (for-each (lambda (file)
-                         (delete-file file))
-                       (find-files "." "\\.bin$"))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))