summary refs log tree commit diff
diff options
context:
space:
mode:
authorJosh Hoff <randomenduser@fastmail.com>2020-10-10 04:55:26 -0500
committerEfraim Flashner <efraim@flashner.co.il>2020-10-14 13:51:26 +0300
commit4835d52efd6aedb14978089785a09baf2be31386 (patch)
tree333b0495a4477e3af31163076ce6b4c7678f0691
parent3df707778a29b7364fffe94c150a9f69467c47cf (diff)
downloadguix-4835d52efd6aedb14978089785a09baf2be31386.tar.gz
gnu: rxvt-unicode: Enable 256 colors
I noticed urxvt has a termcap file for rxvt-256color, but that's not
actually built.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/xdisorg.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d9c89053b9..ccfab58777 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -987,7 +987,8 @@ compact configuration syntax.")
      ;; This sets the destination when installing the necessary terminal
      ;; capability data, which are not provided by 'ncurses'.  See
      ;; https://lists.gnu.org/archive/html/bug-ncurses/2009-10/msg00031.html
-     `(#:make-flags (list (string-append "TERMINFO="
+     `(#:configure-flags (list "--enable-256-color")
+       #:make-flags (list (string-append "TERMINFO="
                                          (assoc-ref %outputs "out")
                                          "/share/terminfo"))
        #:phases